В MySQL обнаружены критические уязвимости повышения привилегий

В MySQL обнаружены критические уязвимости повышения привилегий

В системах управления базами данных MySQL, MariaDB и PerconaDB найдены бреши в безопасности критического уровня, способные привести к повышению привилегий. Разработчики уже выпустили обновления, исправляющие их.

Уязвимости были найдены экспертом Dawid Golunski. В сентябре он обнаружил серьезную уязвимость, приводящую к произвольному выполнению кода в MySQL (CVE-2016-6662). Также исследователь отметил, что ему удалось обнаружить еще одну брешь, получившую идентификатор CVE-2016-6663, благодаря которой эксплуатация CVE-2016-6662 становилась гораздо проще.

На прошлой неделе, исследователь раскрыл подробности CVE-2016-6663, которую Oracle отслеживает, как CVE-2016-5616. Эта брешь позволяет локальному пользователю повысить привилегии и выполнить произвольный код с правами пользователя системы базы данных (например, "MySQL").

Согласно Golunski, злоумышленник может использовать одновременно CVE-2016-6663 и CVE-2016-6662 в качестве связки и таким образом полностью скомпрометировать целевую систему. Эксперт опубликовал видео, показывающее, как работает атака.

«Уязвимость CVE-2016-6663, например, может быть использована злоумышленниками в среде общего хостинга, где у каждого пользователя есть доступ только к определенной базе данных. Также эту брешь могут использовать хакеры, которым удалось взломать сайт и получить доступ к целевой системе как пользователь с низкими привилегиями» - объясняет Golunski.

Подпишитесь
в Facebook

Я уже с вами