Критические бреши в принтерах HP приводят к удаленному выполнению кода

Критические бреши в принтерах HP приводят к удаленному выполнению кода

Сотни струйных принтеров от HP уязвимы для двух критических брешей, которые могут привести к удаленному выполнению кода. HP Product Security Response Team (PSRT) рекомендует всем пользователям как можно скорее обновить свои устройства.

Команда разработчиков опубликовала информацию, в которой говорится следующее:

«В некоторых струйных принтерах были обнаружены две уязвимости. Вредоносный файл, отправленный на одно из таких устройств, может вызвать переполнение стека или статического буфера, что позволит удаленно выполнить произвольный код».

Всего затронуто 166 модели устройств для печати, которые используются на предприятиях. Скорее всего, эти принтеры подключены к сетям компаний, однако пока непонятно, как данные бреши можно использовать для дальнейшего проникновения в сеть.

Список затронутых моделей выглядит так:

  • OfficeJet
  • DeskJet
  • Envy
  • DesignJet
  • PageWide Pro

По шкале CVSS эти бреши (CVE-2018-5924 и CVE-2018-5925) оцениваются в 9,8 баллов из 10 возможных.

Компания оперативно выпустила соответствующие обновления, которые необходимо установить как можно скорее, дабы избежать эксплуатации этих дыр злоумышленниками.