Metasploit получил первое крупное обновление за восемь лет

Metasploit получил первое крупное обновление за восемь лет

Впервые за восемь лет Metasploit получил первое крупное мажорное обновление. Metasploit используется подавляющим большинством пентестеров (тестирование на проникновение), то же самое можно сказать и о киберпреступниках.

В новой версии Metasploit 5.0 реализованы новые возможности, а что самое приятное — разработчики обещают более быстрый и регулярный выпуск обновлений своего продукта.

«Мы построили новый график обновлений, так что теперь всех ждут более регулярные релизы. Надеюсь, что новые версии будут выходить каждый год», — говорит Коди Пирс, менеджер по продукту Metasploit.

Прежде всего в новой версии стоит отметить реализацию поддержки таких языков, как Go, Python и Ruby.

«Если вы разработчик на Go или Python, теперь вы можете писать на этих языках, что сделает процесс значительно удобнее», — продолжает Пирс. — «Скажем, вы хотите написать эксплойт, сканер или инструмент под ваши цели — к вашим услугами теперь три языка».

Помимо этого, была добавлена поддержка фреймврка JSON-RPC API. В целом, как считает Пирс, новый релиз поможет запустить Metasploit в массы. Теперь это будет инструмент для всех, а не только для сообщества разработчиков.

Anti-Malware TelegramПодписывайтесь на канал "Anti-Malware" в Telegram, чтобы первыми узнавать о новостях и наших эксклюзивных материалах по информационной безопасности.

Критический баг в одобренном НАТО файрволе Genugate убрали за четыре дня

Возможность обхода аутентификации, выявленная в веб-интерфейсах Genugate, позволяла получить доступ к защищенным устройствам во внутренней сети организации и перенаправить ее трафик на сторонний прокси-сервер. Получив отчет о критической уязвимости, разработчик файрвола устранил ее за четыре дня.

Межсетевой экран Genugate производства Genua представляет собой гибридное программно-аппаратное решение, объединяющее функции пакетного фильтра и шлюза уровня приложений. При этом обе системы устанавливаются на раздельных устройствах. Эффективность этого защитного комбайна высоко оценило правительство Германии; уровень защиты конфиденциальных данных, который обеспечивает Genugate, соответствует требованиям НАТО и Евросоюза.

Уязвимость в файрволе, зарегистрированную под идентификатором CVE-2021-27215, обнаружили в конце января исследователи из SEC Consult (ныне в составе ИТ-компании Atos). Согласно их бюллетеню, причиной появления проблемы является отсутствие проверки данных, вводимых пользователем.

Наличие такого недочета открывает возможность для входа в панель управления из-под любого аккаунта — даже как суперпользователь или несуществующий пользователь. Результатом подобной атаки может быть полная смена настроек файрвола: установленных правил и политик, почтовых фильтров, дополнительной защиты приложений, разрешений на проксирование трафика и т. п.

Эксплуатация уязвимости требует наличия сетевого доступа к Genugate и осуществляется через манипуляцию параметрами запроса HTTP POST при входе в веб-интерфейс. Нормативы для сетей, оперирующих секретными данными, предполагают ограничение доступа к админ-интерфейсам из общей сети. Тем не менее, наличие такой уязвимости, как CVE-2021-27215, — это очень серьезный прокол, требующий от разработчика быстрой реакции.

Наличие проблемы подтверждено для всех прежних выпусков Genugate. Патчи вышли 2 февраля в составе сборок 9.0 / 9.0 Z p19, 9.6 p7 и 10.1 p4. Авторы находки создали экспериментальный эксплойт, но публиковать подробности пока не стали — лишь выложили на YouTube ролик, демонстрирующий PoC-атаку.

Anti-Malware TelegramПодписывайтесь на канал "Anti-Malware" в Telegram, чтобы первыми узнавать о новостях и наших эксклюзивных материалах по информационной безопасности.

RSS: Новости на портале Anti-Malware.ru