Drupal исправили критические уязвимости в трех модулях

Drupal исправили критические уязвимости в трех модулях

Drupal на этой неделе выпустили обновления безопасности для трех модулей, исправив уязвимости критического уровня в них.

Одним из уязвимых модулей является модуль RESTWS. Уязвимость в нем позволяет злоумышленнику выполнить произвольный PHP код с помощью специально созданных запросов, утверждается в заметке.

Согласно Drupal, брешь может быть использована анонимными пользователями. Все версии RESTful Web Services до 7.x-2.6 в линейке 7.x-2.x и до 7.x-1.7 в линейке 7.x-1.x уязвимы. Пользователям настоятельно рекомендуется обновиться как можно скорее.

Еще одна уязвимость критического уровня, позволяющая выполнить произвольный PHP-код была обнаружена в модуле Coder. Этот модуль предназначен для проверки кода, ориентируясь на стандарты.

Однако, поскольку модуль недостаточно проверяет данные, вводимые пользователем в файле с расширением PHP, злоумышленник может анонимно делать запросы непосредственно в этот файл и выполнить произвольный PHP-код. Более того, команда безопасности Drupal обнаружила, что уязвимость может быть использована, даже если модуль не включен.

Coder в линейке 7.x-1.x уязвим до версии 7.x-1.3 и до версии 7.x-2.6 в линейке 7.x-2.x. Пользователям, у которых установлен этот модуль рекомендуется обновить его до последней версии или просто удалить.

Еще одна уязвимость была обнаружена в модуле Webform Multiple File Upload, который позволяет загружать несколько файлов в веб-форму. Брешь в этом модуле также может привести к выполнению произвольного кода, в зависимости от библиотек, доступных на сайте.

Чтобы реализовать уязвимость, злоумышленнику нужно использовать веб-форму с полем Multiple File Input. Обновить свои модули до последней версии рекомендуется пользователям всех версий до 7.x-1.4.

 

Подпишитесь
в Facebook

Я уже с вами