Срочное обновление Google Chrome устраняет критическую уязвимость

Срочное обновление Google Chrome устраняет критическую уязвимость

Google выпустил срочное обновление браузера Chrome для систем Windows, macOS и  Linux. Сообщается, что этот патч устраняет критические уязвимости, поэтому его рекомендуется установить как можно скорее.

Номер релиза — Chrome 77.0.3865.90, в нём разработчики устранили одну критическую уязвимость и ещё три бреши высокой степени риска. Самые опасные из этих дыр позволяют удалённым атакующим получить контроль над системой.

В Google приняли решение пока не раскрывать подробности выявленных уязвимостей, чтобы не спровоцировать волну атак на пользователей. В результате у людей, предпочитающих Chrome, есть несколько дней, чтобы обновить браузер — после этого корпорация опубликует информацию о проблемах безопасности.

На данный момент известна лишь одна деталь. По словам команды безопасности Google, все четыре устраненные уязвимости представляют собой бреши вида use-after-free. Эти дыры находятся в разных компонентах браузера.

Как мы уже отметили выше, одна из уязвимостей получила статус критической. Согласно информации, полученной от разработчиков, с помощью этой бреши злоумышленники могут удаленно выполнить код в системе.

Напомним, что проблемы класса use-after-free подразумевают повреждение памяти, допускающее изменение или повреждение данных. Используя такие уязвимости, киберпреступники могут повысить свои права в системе.

Anti-Malware Яндекс ДзенПодписывайтесь на канал "Anti-Malware" в Яндекс Дзен, чтобы первыми узнавать о новостях и наших эксклюзивных материалах по информационной безопасности.

Злой ПЛК: специалисты нашли новый вектор атаки на ОТ-сети

Специалисты по кибербезопасности рассказали о новом векторе кибератаки, в ходе которой программируемые логические контроллеры (ПЛК) используются в качестве точки входа, позволяющей закрепиться на автоматизированных рабочих местах и позже — проникнуть в ОТ-сети.

Этот вектор получил имя “Evil PLC“. Обнаружившие его специалисты компании Claroty отмечают, что проблема затрагивает программное обеспечение для АРМ проектировщиков от таких компаний, как Rockwell Automation, Schneider Electric, GE, B&R, Xinje, OVARRO и Emerson.

ПЛК, само собой, являются критическим компонентов любых промышленных устройств, в задачи которых входит контроль производственного процесса. Особенно это касается критической информационной инфраструктуры (КИИ).

Помимо оркестрации и автоматизации задач, ПЛК способны стартовать и завершать процессы, а также выводить предупреждения. Именно спектр задач ПЛК сделал их лакомым кусочком для киберпреступников, особенно хорошо подготовленных. Можно вспомнить хотя бы PIPEDREAM (INCONTROLLER).

«Уязвимый софт для рабочих станций часто представляет собой своеобразный мостик между ОТ и корпоративными сетями. Если атакующему удаётся использовать уязвимости на АРМ, он может легко проникнуть внутрь сети, двигаться латерально между системами и получать доступ к другим ПЛК», — пишут исследователи из Claroty.

Evil PLC предоставляет условному злоумышленнику возможность взломать рабочую станцию, получить доступ к другим ПЛК в сети и даже вмешаться в логику контроллера. Список затронутых вендоров с идентификаторами уязвимостей выглядит так:

 

«Поскольку ПЛК хранят дополнительные типы данных, используемые софтом для инженеров, возникает интересная ситуация: неиспользуемые данные, хранящиеся в ПЛК, могут быть модифицированы для управления затронутым софтом», — продолжают объяснять специалисты.

«В большинстве случаев уязвимости существуют из-за того, что ПО полностью доверяет данным, выходящим из ПЛК. Следовательно, никаких дополнительных проверок безопасности не предусмотрено».

Anti-Malware Яндекс ДзенПодписывайтесь на канал "Anti-Malware" в Яндекс Дзен, чтобы первыми узнавать о новостях и наших эксклюзивных материалах по информационной безопасности.

RSS: Новости на портале Anti-Malware.ru