Владельцам сайтов на WordPress срочно нужно обновить движок

Владельцам сайтов на WordPress срочно нужно обновить движок

Владельцам сайтов, работающих на движке WordPress версии ниже 4.8.3, рекомендуется срочно установить обновления. Экспертами была обнаружена уязвимость SQL-инъекций, которая может быть использована для получения контроля над сайтом.

«Версия WordPress 4.8.2, а также более ранние версии, подвержены проблеме, при которой $wpdb->prepare() может создавать небезопасные запросы, приводящие к потенциальной SQL-инъекции (SQLi). Ядро WordPress напрямую не подвержено этой проблеме», - пишет WordPress Foundation.

Эксперт Энтони Феррара (Anthony Ferrara) опубликовал технические детали этой бреши и объяснил, что она была первоначально обнаружена несколько месяцев назад. Специалист винит во всем обновление до версии WordPress 4.8.2, с которым было множество проблем.

Советы пользователям WordPress

Как отмечалось выше, владельцы сайтов должны как можно скорее перейти на WordPress 4.8.3. Феррара также советует обновить любые плагины, которые заменяют $wpdb (например, HyperDB, LudicrousDB).

Подпишитесь
в Facebook

Я уже с вами