Проблема с восстановлением SEPM - Вопросы по Symantec Endpoint Protection - Форумы Anti-Malware.ru Перейти к содержанию
Merlin

Проблема с восстановлением SEPM

Recommended Posts

Merlin

Всем добрый день!

Помогите решить проблему.

Пытаемся восстановить сервер управления SEPM на новом сервере.

Восстанавливаем сертификат сервера, потом базу данных, переконфигурируем сервер.

После этого сервис сервера стартует, но после попытки подключения консоли падает. В чем может быть проблема?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
xck

В системных событиях ОС есть сообщения?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
angel-keeper

1. подозревай, что в системном логе присутствует ошибка типа "Java has finished work with a code -1"

Решение:

В реестре изменить параметры:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\semsrv\parameters\

JVM Option Number 1= -Xmx512m

JVM Option Number 0 =-Xms512m

Изменить sesm.bat:

@start "SESM" "C:\Program Files\Symantec\Symantec Endpoint Protection Manager\jdk\bin\javaw.exe" -Xms512m -Xmx512m....(остальное обрезано)

2. Проблема так же может быть в том, что неправильно работает IIS

Решение:

1. Delete IIS

2. Install SP2 for Windows2003

3. Install IIS

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Merlin

В event log только сообщение: "Служба "Symantec Endpoint Protection Manager" перешла в состояние stopped." ID 7036.

Ошибка java возникала, если после восстановления из Backup не запустить мастер настройки сервера управления.

Установка производится на чистую систему Microsoft Windows Server 2003 32bit, Enterprise Edition Service Pack 2 + MS SQL Server 2005

Версия SEPM 11.0.4014

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Кирилл Керценбаум
Всем добрый день!

Помогите решить проблему.

Пытаемся восстановить сервер управления SEPM на новом сервере.

Восстанавливаем сертификат сервера, потом базу данных, переконфигурируем сервер.

После этого сервис сервера стартует, но после попытки подключения консоли падает. В чем может быть проблема?

А если попробовать с новой БД? Пробовали на сервере прогонять Утилиту диагностики?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
angel-keeper

Я Вас правильно понял:

1. Вы устанавливаете на новый сервер с нуля SEPM

2. Останавливаете службу SEPM

3. Делаете восстановление БД

4. Запускаете мастера настройки сервера управления и перенастраиваете сервер.

Вопросы.

1. На старом сервере БД была встроенная или MSSQL?

2. Пробовали из моего выше написанного поста первое решение?

3. Может лучше попробовать установить MR5 с чистой БД MSSQl? Импортировать политики и настройки со старого сервера?

Примечание: "минимум необходимый для без проблемного восстановления сервера и подключения клиентов при аварии сервера."

Backup.txt

  • keystorePass = "" - пароль сертификата. Находится в конце шестой строчки файла c:\Program Files\Symantec\Symantec Endpoint Protection Manager\Server Private Key Backup\server_2009-07-24-10-30-22.xml
  • DomainId = "" - ID домена. Находится в файле c:\Program Files\Symantec\Symantec Endpoint Protection Manager\data\outbox\agent\0F27807CC0A80164008809CEB8837FAD\Sylink.xml (имя папки "0F27807CC0A80164008809CEB8837FAD" будет другим т.к. оно рендится)
  • Encryption Password = "" - пароль шифрования. Его указывали при установки на старом сервере.
  • IP Address = "" - ИП адрес сервера.
  • Host Name = "" - Имя сервера.
  • Site Name = Локальный сайт (Имя сайта)

Взята информация из файла installation_guide.pdf, раздел 4.

p.s. Прошу Вас подробно(по шагово) описать процедуру восстановления(переноса) сервера SEPM со старого сервера на новый.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Merlin

1) С нуля устанавливается Microsoft Windows Server 2003 32bit, Enterprise Edition SP 2 + MS SQL Server 2005. Используется тот же IP и имя сервера. На старом сервере так же использовался MS SQL 2005

2) Устанавливается SEPM 11.0.4014 (такой же как на старом сервере)

3) Восстанавливается сертификат сервера (это необходимо если есть Backup? В рекомендациях http://service1.symantec.com/SUPPORT/INTER...080820133606935 этот шаг указан перед восстановлением БД)

4) Останавливается служба SEPM.

5) Восстанавливается БД

6) Запускается Мастер настройки сервера управления

Служба SEP запускается и сразу не падает. Запускаю консоль. Ввожу логин-пароль и все...служба падает, выскакивает окно о невозможности подключения к серверу. В event log ошибок нет, только сообщение об остановке с ID 7036.

Release Update 5 (RU5) конечно вариант, но нет пока русского, да и Backup сделан в 4014, хотелось бы разобраться.

Отчет Support Tool:

1.jpg

2.jpg

post-5994-1255334126_thumb.jpg

post-5994-1255334132_thumb.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
angel-keeper

Какие у Вас значения параметров в ветке реестра???

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\semsrv\parameters\

JVM Option Number 1= ??????????

JVM Option Number 0 = ??????????

Пробовали их менять на вот эти???

JVM Option Number 1= -Xmx512m

JVM Option Number 0 =-Xms512m

Я вас правильно понял, что при установке вы создаете базу SQL а не встроенную и в SQL базу восстанавливаете????

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Merlin

Выполнил все рекомендации, но проблема осталась.

JVM Option Number 0 уже было равно 512м

И на старом и на новом сервере Microsoft SQL Server 2005

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Кирилл Керценбаум

Merlin тогда лучше открыть кейс в тех. поддержке

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Merlin
Merlin тогда лучше открыть кейс в тех. поддержке

Уже пытаемся. Всем спасибо!

По результату отпишу

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
angel-keeper

Буду ждать результата тех. поддержки.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

  • Сообщения

    • demkd
      А ничего с этим не сделать старые версии windows проблемные там система сама балуется внедрением потоков при очень низком уровне защиты системных процессов, а эцп вообще ничего не гарантирует когда речь заходит о внедренных потоках, зловред вполне может внедрить поток в системный процесс как с помощью подкинутой в правильное место "легитимной" dll, так и просто создав его, а тот уже в свою очередь внедрить в следующий системный и ищи концы среди вот этого вот всего.
      Все это усугубляется тем что тот же SVCHOST.EXE который был когда запущен может оказаться совсем не системным, хотя путь у него будет правильным как и файл будет иметь валидную эцп и запущен он будет якобы services.exe, в 10ке такое провернуть уже сложнее, а вот 7ке легко, потому урезать лог по принципу "оба файла имеют эцп" никак нельзя.
    • PR55.RP55
      uVS v5.0.6v x64 [http://dsrt.dyndns.org:8888]: Windows 7 Home Basic x64 (NT v6.1 SP1) build 7601 Service Pack 1 [C:\WINDOWS] (!) ПРЕДУПРЕЖДЕНИЕ: Ф зафиксировал внедрение потока C:\WINDOWS\SYSTEM32\SERVICES.EXE [428] внедрил поток [380] в процесс: C:\WINDOWS\SYSTEM32\SVCHOST.EXE [876]   C:\WINDOWS\SYSTEM32\SVCHOST.EXE [1060] внедрил поток [1276] в процесс: C:\WINDOWS\SYSTEM32\SVCHOST.EXE [336] и т.д.  А есть ли смысл выводить в лог десяток - другой аналогичных записей, если все эти файлы  в базе проверенных и у них легальная цифровая?  
    • demkd
      ---------------------------------------------------------
       5.0.6
      ---------------------------------------------------------
       o Добавлено 4 новых ключа автозапуска в список для проверки.

       o Добавлен новый статус "UWP".
         Его получают пакеты приложений универсальной платформы Windows (Universal Windows Platform Apps).

       o Добавлен новый твик #46: Отключить Windows Terminal и очистить реестр.
         Если Windows Terminal активен, в лог выдается предупреждение.
         При обнаружении подозрительных настроек Windows Terminal в конфигурационных файлах, реестре или в каталогах с фрагментами в лог выводится предупреждение.
         Если подозрительная строка найдена в JSON-файле настроек, то в список автозапуска добавляется этот файл с содержимым со статусом "подозрительный".
         В любом случае рекомендуется отключить Windows Terminal, а еще лучше немедленно удалить это из системы.
         Windows Terminal — крайне уязвимый и неоптимизированный кусок кода.

       o Улучшена функция масштабирования удаленного рабочего стола, повышено качество аппаратного апскейла, добавлен параметр "Резкость".
         (Требуется D2D и DX11 на клиентском компьютере)

       o Исправлена старая ошибка в функции отправки ответов серверной части uVS.
         Из-за ошибки в редких случаях могло происходить подвисание серверной и клиентской частей uVS при работе с удаленной системой.

       o Исправлена ошибка в функции завершения серверной части при выходе из удаленной системы.

       o Оптимизирована функция подключения к удаленной системе.

       o Оптимизирована функция сжатия фреймов для DDAL/DDAw режимов: шрифты теперь не теряют яркость, а картинка DDAL практически неотличима от DDA1/DDA2 на глаз, 
         при этом размер сжатого фрейма вырос лишь незначительно.

       o Добавлена x64 версия report_crash.

       o Обновалена функция сбора дампа при падении uVS, функция перенесена в утилиту report_crash, что позволит
         получить максимально точную информацию о произошедшей ошибке.

       o Временно добавлена аппаратная функция обнаружения разрушения списка автозапуска в памяти uVS, что позволит отлавливать сложные в обнаружении ошибки.
         Есть 5 дампов, по которым не удалось выяснить точное место ошибки и эта функция должна помочь найти проблемное место.
         Функция снижает скорость формирования списка на ~5% на современных процессорах.

       o Исправлена ошибка в функции подсчета удаленных ключей реестра.

       o Исправлена ошибка в функции записи параметров при выходе из uVS.

       o Исправлена ошибка разбора JSON-файлов.

       o Исправлена ошибка проверки переменных окружения загруженного пользователя.

       o Из списка доступных для подключения IP-адресов удалены адреса активных VPN.

       
    • PR55.RP55
      * адрес страницы (ReferrerUrl) и адрес самого файла (HostUrl) в метке появились в Windows 10 версии 1703, их записывают браузеры, например Edge и Chrome. В статье показано, как посмотреть эти данные в Windows 11 https://www.comss.ru/page.php?id=22105
    • Ego Dekker
      ESET Cyber Security 10.0.2100  (macOS 13/14/15/26/27)
                                                                                  ●
              Руководство пользователя ESET Cyber Security 10  (PDF-файл)
                                                           
      Полезные ссылки:
      Технологии ESET
      Удаление антивирусов других компаний
      Как удалить ESET Cyber Security?
×