katbert

Symantec Antivirus Corporate Edition

В этой теме 5 сообщений

Продолжение моей истории по переводу большой сети на SAV CE 10.1.8.8000

На отдельную машину, не являющуюся первичным сервером, установил сервер Reporting

БД - стоящий на этой же машине MS SQL 2000, использующийся под другие задачи

Все установилось корректно, однако при попытке войти в веб-интерфейс я лицезрел стандартное сообщение IE

Internal Server Error 500

В поисках причины я проделал действия, описанные в статье

http://service1.symantec.com/SUPPORT/ent-s...006040513034348

Все работало, включая PHP

Чтобы пролить свет на причину сбоя, я нашел файл настроек php.ini в

c:\Program Files\Symantec\Reporting Server\Php

и разрешил в нем отображение ошибок

display_errors = On

И тут же увидел, что сбой происходит на этапе подключения к базе при выполнении кода

$link->Open($dsn, $dbuser, $dbpasswd);

Причем под указанным пользователем я могу подключиться к БД

Вывод напрашивался один - система не видит DSN, хотя я с Панели управления вижу его корректно

Описание DSN хранится в реестре в ветке

HKEY_LOCAL_MACHINE\SOFTWARE\ODBC

После того, как я дял на нее права Всем - веб-интерфейс Reporting заработал

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Рано обрадовался

Теперь другая проблема - в отчетах Reporting фигурирует только первичный сервер

Ранее сервер отчетов был указан в свойствах первичного сервера, почитал документацию - указал на уровне группы

Возможно, при обновлении первичного сервера допустил ошибку

Сначала через установку и удаление программ удалил Reporting agents и консоль System Center

Затем установкой поверх обновил первичный сервер

С компакт-диска установил новую консоль System Center и установил Reorting agent

Теперь в документации нашел, что Reportiong Agent ставится вместе с сервером новой версии

Не в этом ли ошибка?

В журнале IIS машины с Reporting - фиксируются только обращения к upload.php от самого себя, но не от первичного сервера

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Ну вот и поговорили :)

Неполадку устранил - на первичном сервере не работала служба Reporting agents

Запустил ее - и отчеты наполнились данными

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

katbert а Вы почему не хотите мигрировать на SEP? Уже можно, он вполне стабилен, когда устанавливается с нуля, а не поверх предыдущих версий SEP, то проблемы очень редки

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

В том-то и дело, что ставлю не с нуля

В сети, где я сейчас навожу порядок, на рабочих станциях имеются клиенты версий 8.х, 9.х и 10.1.1000

Пока задача - навести порядок, с минимумом побочных эффектов

Уже вижу, что чем старее версия клиенты была - тем больше ошибок при апгрейде

К тому же версию 9 уже и с поддержки сняли

Перед переходом на SEP еще будем проводить внутренне тестирование - так как много заказных приложений

Да и последующая миграция на SEP пройдет гораздо мягче, если все клиенты будут единообразны

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Создайте учетную запись или войдите, чтобы комментировать

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!


Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.


Войти с помощью Facebook Войти Войти с помощью Twitter
Anti-Malware.ru Вконтакте   Anti-Malware.ru в Facebook   Anti-Malware.ru в Twitter   Anti-Malware.ru в LinkedIn   RSS