Symantec Endpoint Protection - Вопросы по Symantec Endpoint Protection - Форумы Anti-Malware.ru Перейти к содержанию

Recommended Posts

mXm

Собственно, сегодня получили вот такой замечательный эффект.

После применения последних 7 патчей MS на Windows 2003 Server R2 (уж не знаю какой именно повлиял), получили на выходе после перезагрузки нестартующий сервис. При попытке зайти в него консолью получаем "could not create java virtual machine".

Снос патчей работоспособность сервера не восстанавливает, равно как и repair путем инсталяшки.

Интерены причины - пути решения проблемы.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Кирилл Керценбаум

mXm к сожалению сложно что-то сказать, тем более вероятнее всего косяк Microsoft. Попробуйте запустить Утилиту Диагностики, если ничего не покажет - то в тех. поддержку

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
mXm

Спасибо, Кирилл. Там, в общем-то, все понятно - не стартует сервис Symantec Endpoint Protection Manager.

Что именно из обновлений тому виной затрудняюсь сказать. Проблему решил путем отката патчей и полной переустановкой серверной части.

Будем ждать реакции Symantec - наверняка их вскоре (если не уже) засыпят запросами.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Ivan0ff

Имею точно такую же проблему, правда сервис SEPM работает, просто не может загрузиться консоль. Пока вышел из положения так: скачал и установил локально консоль с адреса http://localhost:9090, ей и пользуюсь в настоящий момент.

Еще вроде бы не стало работать расписание LiveUpdate, во всяком случае сегодня, пока не зашел в консоль и вручную не обновился, антивирусные базы оставались старыми. Это тоже не есть очень хорошо, т.к. достаточно неудобно вручную каждое утро запускать обновление.

Огромная просьба, если кто сможет решить проблему без деинсталляции обновлений Windows и полной переустановки сервера SEP, отпишитесь пожалуйста.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Кирилл Керценбаум
Огромная просьба, если кто сможет решить проблему без деинсталляции обновлений Windows и полной переустановки сервера SEP, отпишитесь пожалуйста

Лучше всего проблему сможет решить тех. поддержка, но ей о ней нужно узнать - просьба - обратитесь и откройте кейс, наверняка проблема не ограничивается двумя случаями

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
P.J.

Windows 2003 Server R2 SP1 - сервис стартует, консоль запускается

Windows 2003 Server SP2 - сервис стартует, консоль не запускается (Could not create Java virtual machine), однако с другой машины через http://<servername>:9090 консоль запустить можно.

Так открыт case или нет?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Кирилл Керценбаум
Так открыт case или нет?

Вы также можете его открыть

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
P.J.
Вы также можете его открыть

Открыл :rolleyes: 320-188-597

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Кирилл Керценбаум
Открыл 320-188-597

Вижу, скоро с вами свяжутся :rolleyes:

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
P.J.

Пока ответа нету, проверил SEPM с помощью утилиты диагностики SEP Support Tool. Утилита сообщает, что

Error 324.52 MB free physical memory is less then the required 1GB

Но конфигурация этого сервера не менялась с 2005 года, SEPM на нем работает (работал) с 2008-го, начиная с версии 11.0 MR1. Т.е., внезапно SEPM стало нужно 1GB оперативки?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Кирилл Керценбаум
Пока ответа нету

Можете не ждать ответа - позвоните 7-495-6412291 и укажите номер кейса

Т.е., внезапно SEPM стало нужно 1GB оперативки?

Думаю это не при чем

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
aitishnik

Я тоже словил эту ошибку. Зверское гугление сказало, что такая ошибка часто бывает при завышенном max heap size для JRE. Его уменьшение в файле запуска менеджера действительно помогло.

Итак:

1. идём к sesm.bat, на который и смотрит ярлык "Symantec Endpoint Protection Manager" в меню "Пуск", у меня это Program files (x86)\Symantec\Symantec Endpoint Protection Manager\bin;

2. открываем текстовым редактором sesm.bat;

3. и правим в строке запуска значение "-Xmx1024m" на меньшее, к примеру, я написал "-Xmx928m" (размер слизал с обсуждения на каком-то форуме IBM).

Всё. Консоль стартует :)

  • Upvote 10

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
mXm

Очень интересно.

У меня Server 2003 R2 SP2 стоит и сервис точно не стартовал - т.е. мгновенно помирал при попытке запуска с соответствующим сообщением в поп-ап окне.

Хотелось бы дождаться официального ответа техподдержки с объяснением отчего да почему да по какому случаю. Ну и пути решения, конечно же.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
P.J.
Я тоже словил эту ошибку. Зверское гугление сказало, что такая ошибка часто бывает при завышенном max heap size для JRE. Его уменьшение в файле запуска менеджера действительно помогло.

Итак:

1. идём к sesm.bat, на который и смотрит ярлык "Symantec Endpoint Protection Manager" в меню "Пуск", у меня это Program files (x86)\Symantec\Symantec Endpoint Protection Manager\bin;

2. открываем текстовым редактором sesm.bat;

3. и правим в строке запуска значение "-Xmx1024m" на меньшее, к примеру, я написал "-Xmx928m" (размер слизал с обсуждения на каком-то форуме IBM).

Всё. Консоль стартует :)

Подтверждаю, работает!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Glumer
Подтверждаю, работает!

У меня проблемы все те же, кроме того хочу заметить что все клиенты отвалились от сервера.. описанный выше способ позволил запустить консоль, но залогинится все равно не дает, предлагает убедиться запущен ли сервер..

как с этим то быть кто-нибудь знает?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
nesprosta
У меня проблемы все те же, кроме того хочу заметить что все клиенты отвалились от сервера.. описанный выше способ позволил запустить консоль, но залогинится все равно не дает, предлагает убедиться запущен ли сервер..

как с этим то быть кто-нибудь знает?

У вас скорее всего не запущена служба Symantec Endpoint Protection Manager

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
mXm
У вас скорее всего не запущена служба Symantec Endpoint Protection Manager

Так вот она и не стартует у Glumer, видимо. Как и у меня.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
depeche
Так вот она и не стартует у Glumer, видимо. Как и у меня.

Столкнулся с такой же проблемой после автоматического обновления Windows.

Причина в обновлении KB956572, после его удаления и перезагрузки сервер SEPM успешно стартует.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Gronn

Сидел экспериментировал со статическими маршрутами на сервере с SEPM в итоге получил такую беду - на своей машине пытаюсь подключиться через http://server:9090. В итоге имя и пароль принимаются, но через секунду после загрузки косоли предлагает еще раз ввести. войти в консоль получается раза с третьего. а иногда в консоль входит, но доступны все страницы а служба репортов висит с приглашением ввести имя и пароль. вернул все маршруты обратно, но беда осталась. перезагрузки не помогли. менял java на несколько версий от 1.5 до 1.6.7 (думал проблема в моей машине), но даже на любой другой машине та же беда. на самом сервере все запускается замечательно. может это веб сервре глюканул?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Gronn

Суппорт тул показал такие ошибки на сервере:

Name: WpsHelper

Type: Kernel Driver

Status Setting Default Actual

Error State Running Stopped

Error Exit Code С момента последней загрузки попытки запустить службу не делались.

Ok Start Type Demand Start Demand Start

Ok Log On As LocalSystem LocalSystem

Все остальное ОК.

На клиенте есть незначительные предупреждения...

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Кирилл Керценбаум
может это веб сервре глюканул?

Похоже на проблемы с IIS

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
angel-keeper

После установки обновления kb(956572) перестает запускаться служба Symantec Endpoint Protection Manager.

В логе AppEvent.Evt создаются две записи:

1. Could not initialize the Java Virtual Machine.(код 4096)

2. The semsrv service failed to start.(код 4098)

При попытки запустить Symantec Endpoint Protection Manager Console выдается ошибка Could not create the Java Virtual Machine.

После удаления обновления kb(956572) служба Symantec Endpoint Protection Manager запускается без проблем.

В тех.поддержке открыл кейс

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Glumer
Столкнулся с такой же проблемой после автоматического обновления Windows.

Причина в обновлении KB956572, после его удаления и перезагрузки сервер SEPM успешно стартует.

Подтверждаю, снос этого обновления восстановил работоспособность службы на серваке, но у клиентов так и не загорается зеленый индикатор на иконке.. видимо придется еще на всех клиентских машинах сносить это обновление :((

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Glumer
Подтверждаю, снос этого обновления восстановил работоспособность службы на серваке, но у клиентов так и не загорается зеленый индикатор на иконке.. видимо придется еще на всех клиентских машинах сносить это обновление :((

Действительно, снес это гнусное обновление на клиент, и он зацепился нормально

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
angel-keeper

Для того чтобы исправить эту ошибку необходимо сделать следующее

1) в реестре

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\semsrv\parameters\

параметры

JVM Option Number 1= -Xmx512m

JVM Option Number 0 =-Xms512m

2) Изменить sesm.bat следующим образом

@start "SESM" "C:\Program Files\Symantec\Symantec Endpoint Protection Manager\jdk\bin\javaw.exe" -Xms512m -Xmx512m....(остальное обрезано)

(с) тех.поддержка.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

  • Сообщения

    • demkd
      А ничего с этим не сделать старые версии windows проблемные там система сама балуется внедрением потоков при очень низком уровне защиты системных процессов, а эцп вообще ничего не гарантирует когда речь заходит о внедренных потоках, зловред вполне может внедрить поток в системный процесс как с помощью подкинутой в правильное место "легитимной" dll, так и просто создав его, а тот уже в свою очередь внедрить в следующий системный и ищи концы среди вот этого вот всего.
      Все это усугубляется тем что тот же SVCHOST.EXE который был когда запущен может оказаться совсем не системным, хотя путь у него будет правильным как и файл будет иметь валидную эцп и запущен он будет якобы services.exe, в 10ке такое провернуть уже сложнее, а вот 7ке легко, потому урезать лог по принципу "оба файла имеют эцп" никак нельзя.
    • PR55.RP55
      uVS v5.0.6v x64 [http://dsrt.dyndns.org:8888]: Windows 7 Home Basic x64 (NT v6.1 SP1) build 7601 Service Pack 1 [C:\WINDOWS] (!) ПРЕДУПРЕЖДЕНИЕ: Ф зафиксировал внедрение потока C:\WINDOWS\SYSTEM32\SERVICES.EXE [428] внедрил поток [380] в процесс: C:\WINDOWS\SYSTEM32\SVCHOST.EXE [876]   C:\WINDOWS\SYSTEM32\SVCHOST.EXE [1060] внедрил поток [1276] в процесс: C:\WINDOWS\SYSTEM32\SVCHOST.EXE [336] и т.д.  А есть ли смысл выводить в лог десяток - другой аналогичных записей, если все эти файлы  в базе проверенных и у них легальная цифровая?  
    • demkd
      ---------------------------------------------------------
       5.0.6
      ---------------------------------------------------------
       o Добавлено 4 новых ключа автозапуска в список для проверки.

       o Добавлен новый статус "UWP".
         Его получают пакеты приложений универсальной платформы Windows (Universal Windows Platform Apps).

       o Добавлен новый твик #46: Отключить Windows Terminal и очистить реестр.
         Если Windows Terminal активен, в лог выдается предупреждение.
         При обнаружении подозрительных настроек Windows Terminal в конфигурационных файлах, реестре или в каталогах с фрагментами в лог выводится предупреждение.
         Если подозрительная строка найдена в JSON-файле настроек, то в список автозапуска добавляется этот файл с содержимым со статусом "подозрительный".
         В любом случае рекомендуется отключить Windows Terminal, а еще лучше немедленно удалить это из системы.
         Windows Terminal — крайне уязвимый и неоптимизированный кусок кода.

       o Улучшена функция масштабирования удаленного рабочего стола, повышено качество аппаратного апскейла, добавлен параметр "Резкость".
         (Требуется D2D и DX11 на клиентском компьютере)

       o Исправлена старая ошибка в функции отправки ответов серверной части uVS.
         Из-за ошибки в редких случаях могло происходить подвисание серверной и клиентской частей uVS при работе с удаленной системой.

       o Исправлена ошибка в функции завершения серверной части при выходе из удаленной системы.

       o Оптимизирована функция подключения к удаленной системе.

       o Оптимизирована функция сжатия фреймов для DDAL/DDAw режимов: шрифты теперь не теряют яркость, а картинка DDAL практически неотличима от DDA1/DDA2 на глаз, 
         при этом размер сжатого фрейма вырос лишь незначительно.

       o Добавлена x64 версия report_crash.

       o Обновалена функция сбора дампа при падении uVS, функция перенесена в утилиту report_crash, что позволит
         получить максимально точную информацию о произошедшей ошибке.

       o Временно добавлена аппаратная функция обнаружения разрушения списка автозапуска в памяти uVS, что позволит отлавливать сложные в обнаружении ошибки.
         Есть 5 дампов, по которым не удалось выяснить точное место ошибки и эта функция должна помочь найти проблемное место.
         Функция снижает скорость формирования списка на ~5% на современных процессорах.

       o Исправлена ошибка в функции подсчета удаленных ключей реестра.

       o Исправлена ошибка в функции записи параметров при выходе из uVS.

       o Исправлена ошибка разбора JSON-файлов.

       o Исправлена ошибка проверки переменных окружения загруженного пользователя.

       o Из списка доступных для подключения IP-адресов удалены адреса активных VPN.

       
    • PR55.RP55
      * адрес страницы (ReferrerUrl) и адрес самого файла (HostUrl) в метке появились в Windows 10 версии 1703, их записывают браузеры, например Edge и Chrome. В статье показано, как посмотреть эти данные в Windows 11 https://www.comss.ru/page.php?id=22105
    • Ego Dekker
      ESET Cyber Security 10.0.2100  (macOS 13/14/15/26/27)
                                                                                  ●
              Руководство пользователя ESET Cyber Security 10  (PDF-файл)
                                                           
      Полезные ссылки:
      Технологии ESET
      Удаление антивирусов других компаний
      Как удалить ESET Cyber Security?
×