Universal Virus Sniffer (uVS), Вопросы разработчику - Страница 57 - Universal Virus Sniffer (uVS) - развитие, использование и решение проблем - Форумы Anti-Malware.ru Перейти к содержанию

Recommended Posts

Sergey Dindikov

дополнение:

запускал через start.exe, 2003- контроллер домена.

тест был uvs_v3811

проверил запуск на win8 pro на виртуалке

uvs_v3811/uvs всё ok.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
demkd

Sergey Dindikov

спасибо, посмотрю

мелкого файла более чем достаточно :) uvs.dmp не нужен

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
demkd

мда, командная строка процесса длинной более 2к символов, короче надо будет переделывать движок, когда - хз.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
alamor

Тут нельзя установить статус проверенный объектам у кого производитель CyberLink

eb3678f7a10760f1ce35f98801bd200e.jpeg

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
demkd

alamor

сертификат аннулирован потому и нельзя, тут надо подумать

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Sergey Dindikov

ком строка = 3796 символов (это процесс Lotus Notes 9)

http://screencast.com/t/oYzBnTaxvVt

если процесс не запущен то всё ok - UVS работает

а что насчёт не запуска под Local System?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
demkd
а что насчёт не запуска под Local System?

а это надо поднимать контроллер домена, а так у меня на виртуалке запускается без проблем, поднять пока руки не дошли

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Sergey Dindikov
а это надо поднимать контроллер домена, а так у меня на виртуалке запускается без проблем, поднять пока руки не дошли

2008R2 x64 - не контроллер домена и трабла есть....

чуть позже проверю на другой 2003 тоже контроллер.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
demkd
2008R2 x64 - не контроллер домена и трабла есть....

а ну тогда поставлю, где-то у меня валялся r2

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Sergey Dindikov

так на моих 2003/2008 разные проблемы!!!

под w2008r2 x64 когда выбираю запуск под local system

как я говорил инит и запуск сервиса как бы удачно проходит но визуально окно

UVS я не вижу, Process Explorer показал:

http://screencast.com/t/quzaZRcNpS

те такое ощущение что просто не хватает Interact with desktop

psexec -s -i C:\3\uvs.exe

UVS запустился нормально под Local System

psexec -s -i C:\3\start.exe и выбирая запуск под текущим юзером

UVS запустился нормально под Local System

------------------------------8<--- CUT HERE ---8<------------------------------

на 2003 x86 контроллер домена

psexec -s -i C:\3\uvs.exe

UVS запустился нормально под Local System

psexec -s -i C:\3\start.exe и выбирая запуск под текущим юзером

UVS запустился нормально под Local System

на втором контроллере 2003 таже самая ситуация!!! напомню

запускаю под админом start

при попытке запуска UVS под local system через меню

сразу выдается

---------------------------

Ошибка

---------------------------

Не удалось запустить процесс под LocalSystem!

---------------------------

OK

---------------------------

может сделаешь какую-то логгируемую сборку для меня на этом моменте?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
demkd
те такое ощущение что просто нехватает Interact with desktop

а его и нет уже с висты, там механизм запуска процесса иной, сперва сам посмотрю а там видно будет или лог какой расширенный или еще что

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Sergey Dindikov

Эээээ забыл написать что все тесты под 2003/2008 были в RDP сесcии

не знаю насколько это важно.....

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
santy

а поддержка сети работает при запуске uVS под учеткой LocalSystem?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
demkd

santy

из под LS нет доступа к сети

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
santy

demkd,

может поэтому и запуск из под LS идет с ошибкой под RDP, поскольку сессия с хоста должна транслироваться по сети на удаленный рабочий стол?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
demkd

santy

вряд ли

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Sergey Dindikov

да проверил на 2003 в основной сессии работает запуск под localsystem (учётка таже что и по RDP входил)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Sergey Dindikov
да проверил на 2003 в основной сессии работает запуск под localsystem (учётка таже что и по RDP входил)

на 2008 тоже всё ok при запуске в основной сессии.

может сделать запуск также как это делает psexec? у неё ведь проблем нет с запуском.......

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
demkd

Sergey Dindikov

дело не в том как запускается, дело походу в том что rdp создает свой десктоп, я не проверял конечно, но скорее всего дело в этом

проверить легко запустить через rdp и потом подключится как к удаленному компьютеру, вдавить alt+v и пощелкать кнопкой переключения десктопов, скорее всего uvs таки найдется на одном из них, если дело в этом, то адаптация под rdp много времени не займет :)

пока просто руки не доходят заняться uVS, постоянно неотложные дела всплывают.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
demkd

проверил, все именно так и есть, uVS запускается на дефолтном рабочем столе, а не на rdp в котором произошел запуск uVS,

проблема есть для серверных систем, на десктопных проблемы нет поскольку рабочий стол для rdp совпадает с дефолтным,

буду чинить, пока правда непонятно как именно.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Sergey Dindikov

demkd

проверил 3.81.2

2 мои проблемы исчезли - биг сенькс =)

ещё пожелание: хотелось бы иметь возможность закрытия программы во время сканирования. Сейчас это возможно только если убивать процесс.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
demkd

Sergey Dindikov

Там возни много, а необходимость в этом не слишком большая.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
PR55.RP55
Demkd пишет: Там возни много, а необходимость в этом не слишком большая.

Есть штатная работа с программой.

Есть тестовая работа с программой.

+

Есть ситуации перегрузки процессора и соответственно невозможность продолжить работу с программой.

Пример: программ зависает на 97% - её нужно закрыть и после проанализировать ситуацию.

Как её закрыть ?

Приходиться применять доп. средства.

Поддерживаю предложение Сергея - ( хотя бы при работе с тестовыми версиями uVS )

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Пожалуйста, войдите, чтобы комментировать

Вы сможете оставить комментарий после входа в



Войти

  • Сообщения

    • demkd
      Да есть такой баг, выбор целого диска не предусмотрел.
    • PR55.RP55
      Сейчас попробовал добавить файлы и... E:\ [Error: 0x3 - The system cannot find the path specified. ] т.е. Файл > Добавить в список >  Все исполняемые файлы каталога. или пишет вышеуказанную ошибку или вешается. Это и на Win 7 и на Win 10 и с HDD дисками и с USB Диски нормально открываются т.е. доступны.
    • demkd
      А ничего с этим не сделать старые версии windows проблемные там система сама балуется внедрением потоков при очень низком уровне защиты системных процессов, а эцп вообще ничего не гарантирует когда речь заходит о внедренных потоках, зловред вполне может внедрить поток в системный процесс как с помощью подкинутой в правильное место "легитимной" dll, так и просто создав его, а тот уже в свою очередь внедрить в следующий системный и ищи концы среди вот этого вот всего.
      Все это усугубляется тем что тот же SVCHOST.EXE который был когда запущен может оказаться совсем не системным, хотя путь у него будет правильным как и файл будет иметь валидную эцп и запущен он будет якобы services.exe, в 10ке такое провернуть уже сложнее, а вот 7ке легко, потому урезать лог по принципу "оба файла имеют эцп" никак нельзя.
    • PR55.RP55
      uVS v5.0.6v x64 [http://dsrt.dyndns.org:8888]: Windows 7 Home Basic x64 (NT v6.1 SP1) build 7601 Service Pack 1 [C:\WINDOWS] (!) ПРЕДУПРЕЖДЕНИЕ: Ф зафиксировал внедрение потока C:\WINDOWS\SYSTEM32\SERVICES.EXE [428] внедрил поток [380] в процесс: C:\WINDOWS\SYSTEM32\SVCHOST.EXE [876]   C:\WINDOWS\SYSTEM32\SVCHOST.EXE [1060] внедрил поток [1276] в процесс: C:\WINDOWS\SYSTEM32\SVCHOST.EXE [336] и т.д.  А есть ли смысл выводить в лог десяток - другой аналогичных записей, если все эти файлы  в базе проверенных и у них легальная цифровая?  
    • demkd
      ---------------------------------------------------------
       5.0.6
      ---------------------------------------------------------
       o Добавлено 4 новых ключа автозапуска в список для проверки.

       o Добавлен новый статус "UWP".
         Его получают пакеты приложений универсальной платформы Windows (Universal Windows Platform Apps).

       o Добавлен новый твик #46: Отключить Windows Terminal и очистить реестр.
         Если Windows Terminal активен, в лог выдается предупреждение.
         При обнаружении подозрительных настроек Windows Terminal в конфигурационных файлах, реестре или в каталогах с фрагментами в лог выводится предупреждение.
         Если подозрительная строка найдена в JSON-файле настроек, то в список автозапуска добавляется этот файл с содержимым со статусом "подозрительный".
         В любом случае рекомендуется отключить Windows Terminal, а еще лучше немедленно удалить это из системы.
         Windows Terminal — крайне уязвимый и неоптимизированный кусок кода.

       o Улучшена функция масштабирования удаленного рабочего стола, повышено качество аппаратного апскейла, добавлен параметр "Резкость".
         (Требуется D2D и DX11 на клиентском компьютере)

       o Исправлена старая ошибка в функции отправки ответов серверной части uVS.
         Из-за ошибки в редких случаях могло происходить подвисание серверной и клиентской частей uVS при работе с удаленной системой.

       o Исправлена ошибка в функции завершения серверной части при выходе из удаленной системы.

       o Оптимизирована функция подключения к удаленной системе.

       o Оптимизирована функция сжатия фреймов для DDAL/DDAw режимов: шрифты теперь не теряют яркость, а картинка DDAL практически неотличима от DDA1/DDA2 на глаз, 
         при этом размер сжатого фрейма вырос лишь незначительно.

       o Добавлена x64 версия report_crash.

       o Обновалена функция сбора дампа при падении uVS, функция перенесена в утилиту report_crash, что позволит
         получить максимально точную информацию о произошедшей ошибке.

       o Временно добавлена аппаратная функция обнаружения разрушения списка автозапуска в памяти uVS, что позволит отлавливать сложные в обнаружении ошибки.
         Есть 5 дампов, по которым не удалось выяснить точное место ошибки и эта функция должна помочь найти проблемное место.
         Функция снижает скорость формирования списка на ~5% на современных процессорах.

       o Исправлена ошибка в функции подсчета удаленных ключей реестра.

       o Исправлена ошибка в функции записи параметров при выходе из uVS.

       o Исправлена ошибка разбора JSON-файлов.

       o Исправлена ошибка проверки переменных окружения загруженного пользователя.

       o Из списка доступных для подключения IP-адресов удалены адреса активных VPN.

       
×