Перейти к содержанию
Лёлик

После обновления officescan 10.5--->10.6 на xp не запускается сервис officescan listener

Recommended Posts

Лёлик

Здравствуйте.

Недавно обновил officescan 10.5 на версию 10.6. Обновление прошло успешно. Все клиенты подхватили обновление. На windows vista-7 все нормально, а на xp не запускается сервис officescan nt listener. Пишет что не найден сервис netprofm от которого nt listener зависит. НО на xp никогда этого сервиса не было! Как исправить проблему?

Если в реестре убираю зависимость nt listener от netprofm, то после первой перезагрузки все нормально - listener запускается. Но уже после второй перезагрузки снова появляется зависимость от netprofm и сервис не стартует.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Alexey Dudnikov

попробовал ваш сценарий - все работает, nt listener зависит только от RPC

понимаю, что тривиально - а если переставить заново, проблема остается?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Лёлик

Да остается. Поставил заново на xp . Nt listener зависит от трех служб

Netman

WinMgmt

netprofm

На windows 7 те же зависимости, но в ней netprofm есть и поэтому запускается нормально.

Неужели у вас только одна зависимость? Интересно еще у кого как?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Alexey Dudnikov

хорошо, пойдем другим путем. речь идет об этих зависимостях?

http://fastpic.ru/view/29/2011/1122/651700...732e00.png.html

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Лёлик

Да именно о них.

Но в реестре в ключе HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\tmlisten это выглядит так

DependOnService Netman WinMgmt netprofm

т.е. добавлена еще одна зависимость netprofm

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Alexey Dudnikov

эта проблема на всех windows xp?

все XP 32-битные?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Лёлик

Я уже создал на всех рабочих станциях с xp сервис c именем netprofm . Он запускается, Listener видит что сервис запущен и стартует сам.

Но ведь это не решение проблемы! Применять такие методы крайний случай. Но у меня клиенты из-за этой ошибки несколько дней не получали обновлений поэтому пришлось так сделать.

Пробовал просто в реестре убирать netprofm из зависимостей. Но officescan восстанавливает реестр и netprofm появляется снова.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Alexey Dudnikov

а есть возможность поднять сервер OSCE 10.6 "с нуля" и установить одного агента на windows xp?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Лёлик

Специально выделенных компьютеров для тестирования нет, а на рабочем сервере не желательно проводить эксперименты...

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Alexey Dudnikov

сервер OSCE можно поднять даже на рабочей станции windows xp/vista/7

как вариант - могу выложить дистрибутив клиента OSCE 10.6 для тестирования на windows xp и если все заработает - значит произошел глюк при переходе на 10.6 и надо просто переставить сервер (это можно сделать с сохранением настроек и не теряя существующих windows 7.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Лёлик

Спасибо что помогаете. Дистрибутив у меня есть.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Alexey Dudnikov

тогда установите чистый сервер и на одну из проблемных XP установите клиент OSCE, обязательно отпишите о результатах.

по другому можно - снять логи с помощью программы CDT и отправить в тех поддержку трендов, но быстрее поставить самому с нуля, к тому же можно сохранить нормальных клиентов (не переставляя их)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Лёлик

Да я вроде проблему решил. Криво конечно, но работает. Как будет побольше свободного времени проведу эксперимент и обязательно отпишу.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

×