Проблема со встроенной базой данных - Вопросы по Symantec Endpoint Protection - Форумы Anti-Malware.ru Перейти к содержанию
sergtmb2007

Проблема со встроенной базой данных

Recommended Posts

sergtmb2007

Добрый день.

Проблема такого характера. На Windows Server 2003 стояла консоль с подключенными клиентами (порядка 40). Централизованно поступил сервер с Windows Server 2008. Решил перетащить консоль на него, а с 2003 удалил. Консоль встала, но были проблемы с клиентами. Решил вернуть все на 2003. Переустановил консоль, клиентов (используется встроенная база данных). Все бы ничего, но стала отключаться служба встроенной базы (тип запуска - авто) и соответственно не обновляются клиенты, значок в трее на клиентах без зеленого кружка. После запуска службы клиенты обновляются, но не все, видно зависит от самих клиентов (просто не успевают) и через некоторое время (точно не засекал, но где-то около 5 минут) служба опять останавливается. Достало уже сил нет. Подскажите, что можно сделать. Пусть даже если полностью все снести, главное, чтобы помогло.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Shell

Поднимите второй сервер, реплицируйте политики, мигрируйте на него клиентов.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
sergtmb2007
Поднимите второй сервер, реплицируйте политики, мигрируйте на него клиентов.

Спасибо, попробую. Кроме того, стал периодически выдавать ошибку при входе в консоль - Непредвиденная ошибка сервера. Сответственно в консоль войти не могу, спасает только перезагрузка...

И все это после сбоя (неожиданно отключили электричество, пришло восстанавливать систему через chkdsk). Может че-то в системных файлах не так?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
sergtmb2007
Поднимите второй сервер, реплицируйте политики, мигрируйте на него клиентов.

Основная проблема оказалась в том, что отключается служба встроенной базы. Если ее включить вручную, то и в консоль входишь без проблем и непредвиденных ошибок нет, и клиенты обновляются. Но проходит минут пять эта зараза (т.е. служба) опять отключается, хотя тип запуска стоит Авто. И как с ней бороться, ума не приложу....

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
xck

Посмотри логи приложений в своей OS, останов сервиса должен быть отображен в данных логах с причиной останова. Так же причина может быть указана в файле - scm-server-0.log (..... Symantec Endpoint Protection Manager\tomcat\logs\)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
maket84

всем доброго времени суток.

у меня следующая проблема.

не могу достучаться до своего сервера.

служба Symantec Endpoint Protection Manager(SemSvc.exe) постоянно останавливается, хотя стоит автоматик.

вручную запускаю но она тут же останавливается.(проходит 10 секунд)

В Event Viewer следующие ошибки:

Виртуальная машина Java завершила работу с кодом 1, служба останавливается.

Перезапускал службу Встроенная база данных Symantec.

лог такой:

The description for Event ID 1 from source ASA 9.0 cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

ASANYs_sem5

Normal shutdown of service ASANYs_sem5

___

The description for Event ID 1 from source ASA 9.0 cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

ASANYs_sem5

Starting service ASANYs_sem5

___

The description for Event ID 1 from source ASA 9.0 cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

ASANYs_sem5

Successfully started service ASANYs_sem5

Содержимое файла scm-server-0.log

2011-02-02 15:47:53.947 SEVERE: ================== Server Environment ===================

2011-02-02 15:47:53.948 SEVERE: os.name = Windows Server 2008

2011-02-02 15:47:53.949 SEVERE: os.version = 6.0

2011-02-02 15:47:53.949 SEVERE: os.arch = x86

2011-02-02 15:47:53.950 SEVERE: java.version = 1.6.0_14

2011-02-02 15:47:53.950 SEVERE: java.vendor = Sun Microsystems Inc.

2011-02-02 15:47:53.950 SEVERE: java.vm.name = Java HotSpot Server VM

2011-02-02 15:47:53.951 SEVERE: java.vm.version = 14.0-b16

2011-02-02 15:47:53.951 SEVERE: java.home = C:\Program Files (x86)\Symantec\Symantec Endpoint Protection Manager\jdk\jre

2011-02-02 15:47:53.952 SEVERE: catalina.home = C:\Program Files (x86)\Symantec\Symantec Endpoint Protection Manager\tomcat

2011-02-02 15:47:53.952 SEVERE: java.user = null

2011-02-02 15:47:53.952 SEVERE: user.language = ru

2011-02-02 15:47:53.952 SEVERE: user.country = RU

2011-02-02 15:47:53.952 SEVERE: scm.server.version = 11.0.5002.333

2011-02-02 15:47:58.523 SEVERE: ================== StartClientTransport ===================

2011-02-02 15:47:59.016 SEVERE: Schedule is started!

*версия старая стоит потому что это резервный сервер. на основном переставляли ОС. поэтому на резервный поставил такую версию.

гугл и форум много похожих проблем дают. но они почему то без решения.

ссылки

http://www.symantec.com/business/support/i...mp;locale=en_US

http://www.symantec.com/business/support/i...mp;locale=en_US

не особо помогли.

Если сейчас поднять на втором серваке SEP - репликация ведь не пройдет если тут служба не запущена?

буду благодарен вашим советам.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Олег Просветов
всем доброго времени суток.

у меня следующая проблема.

не могу достучаться до своего сервера.

служба Symantec Endpoint Protection Manager(SemSvc.exe) постоянно останавливается, хотя стоит автоматик.

вручную запускаю но она тут же останавливается.(проходит 10 секунд)

Добрый день,

Похоже на проблему со встроеной БД, попробуйте запустить dbvalidator для проверки целостности. Статья, как это сделать - http://www.symantec.com/business/support/i...mp;locale=en_US

С уважением,

Олег

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
maket84
Добрый день,

Похоже на проблему со встроеной БД, попробуйте запустить dbvalidator для проверки целостности. Статья, как это сделать - http://www.symantec.com/business/support/i...mp;locale=en_US

С уважением,

Олег

сделал обновление SEPM до версии 11.0.6005.562

все установилось но в консоль опять не пустил с той же ошибкой. =(

базу проверил.

Database validation passed.

INFO: Finished.

поднял виртуальный сервер. поставил на нем "с нуля" SEMP, потом подсунул архив базы(правда сделанный после обнаружения проблемы).

пробую прицепиться но все тоже самое. служба SEMP останавливается.

ИТОГ.

позвонил в саппорт симантек - создали инцидент

перезвонили из ТП.

спросили смогу ли я организовать доступ или вышлю логи.

я выбрал первое. зашел на указанный сайт. вобщем есть в Симантеке Remote support. =)

он открыл файл catalina.out глянул ошибку. сказал что порт 8005 у меня занят каким то приложением.

далее в tomcat\conf в файле server.xml поменял 8005 на 8006 перезапустил iis и вуаля! все заработало.

точное содержимое лога catalina.out не скажу. потому что после исправления у него поменялось содержимое.

чем у меня занят 8005 я так и не нашел. =( хотя есть предположение что дело в HP ProCurve Manager+

Потому что именно после установки PCM+ пропала связь с SEPM

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

  • Сообщения

    • PR55.RP55
      uVS v5.0.6v x64 [http://dsrt.dyndns.org:8888]: Windows 7 Home Basic x64 (NT v6.1 SP1) build 7601 Service Pack 1 [C:\WINDOWS] (!) ПРЕДУПРЕЖДЕНИЕ: Ф зафиксировал внедрение потока C:\WINDOWS\SYSTEM32\SERVICES.EXE [428] внедрил поток [380] в процесс: C:\WINDOWS\SYSTEM32\SVCHOST.EXE [876]   C:\WINDOWS\SYSTEM32\SVCHOST.EXE [1060] внедрил поток [1276] в процесс: C:\WINDOWS\SYSTEM32\SVCHOST.EXE [336] и т.д.  А есть ли смысл выводить в лог десяток - другой аналогичных записей, если все эти файлы  в базе проверенных и у них легальная цифровая?  
    • demkd
      ---------------------------------------------------------
       5.0.6
      ---------------------------------------------------------
       o Добавлено 4 новых ключа автозапуска в список для проверки.

       o Добавлен новый статус "UWP".
         Его получают пакеты приложений универсальной платформы Windows (Universal Windows Platform Apps).

       o Добавлен новый твик #46: Отключить Windows Terminal и очистить реестр.
         Если Windows Terminal активен, в лог выдается предупреждение.
         При обнаружении подозрительных настроек Windows Terminal в конфигурационных файлах, реестре или в каталогах с фрагментами в лог выводится предупреждение.
         Если подозрительная строка найдена в JSON-файле настроек, то в список автозапуска добавляется этот файл с содержимым со статусом "подозрительный".
         В любом случае рекомендуется отключить Windows Terminal, а еще лучше немедленно удалить это из системы.
         Windows Terminal — крайне уязвимый и неоптимизированный кусок кода.

       o Улучшена функция масштабирования удаленного рабочего стола, повышено качество аппаратного апскейла, добавлен параметр "Резкость".
         (Требуется D2D и DX11 на клиентском компьютере)

       o Исправлена старая ошибка в функции отправки ответов серверной части uVS.
         Из-за ошибки в редких случаях могло происходить подвисание серверной и клиентской частей uVS при работе с удаленной системой.

       o Исправлена ошибка в функции завершения серверной части при выходе из удаленной системы.

       o Оптимизирована функция подключения к удаленной системе.

       o Оптимизирована функция сжатия фреймов для DDAL/DDAw режимов: шрифты теперь не теряют яркость, а картинка DDAL практически неотличима от DDA1/DDA2 на глаз, 
         при этом размер сжатого фрейма вырос лишь незначительно.

       o Добавлена x64 версия report_crash.

       o Обновалена функция сбора дампа при падении uVS, функция перенесена в утилиту report_crash, что позволит
         получить максимально точную информацию о произошедшей ошибке.

       o Временно добавлена аппаратная функция обнаружения разрушения списка автозапуска в памяти uVS, что позволит отлавливать сложные в обнаружении ошибки.
         Есть 5 дампов, по которым не удалось выяснить точное место ошибки и эта функция должна помочь найти проблемное место.
         Функция снижает скорость формирования списка на ~5% на современных процессорах.

       o Исправлена ошибка в функции подсчета удаленных ключей реестра.

       o Исправлена ошибка в функции записи параметров при выходе из uVS.

       o Исправлена ошибка разбора JSON-файлов.

       o Исправлена ошибка проверки переменных окружения загруженного пользователя.

       o Из списка доступных для подключения IP-адресов удалены адреса активных VPN.

       
    • PR55.RP55
      * адрес страницы (ReferrerUrl) и адрес самого файла (HostUrl) в метке появились в Windows 10 версии 1703, их записывают браузеры, например Edge и Chrome. В статье показано, как посмотреть эти данные в Windows 11 https://www.comss.ru/page.php?id=22105
    • Ego Dekker
      ESET Cyber Security 10.0.2100  (macOS 13/14/15/26/27)
                                                                                  ●
              Руководство пользователя ESET Cyber Security 10  (PDF-файл)
                                                           
      Полезные ссылки:
      Технологии ESET
      Удаление антивирусов других компаний
      Как удалить ESET Cyber Security?
    • Ego Dekker
      Домашние антивирусы для Windows были обновлены до версии 19.2.10.
×