SEPM не работает Домашняя страница - Вопросы по Symantec Endpoint Protection - Форумы Anti-Malware.ru Перейти к содержанию
W0rm

SEPM не работает Домашняя страница

Recommended Posts

W0rm

Есть 2 сервера управления на одной базе SQL, в течении первой недели после установки отчеты просматривал без проблем, потом стали формировались через раз и сейчас единственное что видно: Unexpected error. На обоих серверах.

Подскажите что можно сделать?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Shell
Есть 2 сервера управления на одной базе SQL, в течении первой недели после установки отчеты просматривал без проблем, потом стали формировались через раз и сейчас единственное что видно: Unexpected error. На обоих серверах.

Подскажите что можно сделать?

SEPM и IIS службы запущены? Через веб доступны?

Сделайте рестарт SEPM.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
WhiteFox

Добрый день!

Вопрос по SEP Manager

В консоли на закладке Главная, Мониторы, Отчеты не отображаются отчеты. Видны только пустые бланки. Остальные интерфейсы работают нормально.

Версия 11.0.5002.333. Обновление до версии 11.0.6005.562 ошибку не исправило.

ОС: win2003 SRV ENG R2

При подкючении В удаленном сеансе (RDP) на сервер с установленным SEP Manager ошибок не выдает, но отчетов нет. При подключении к серверу удаленно

появляется ошибка web-страницы

"Строка: 928

Ошибка: Предполагается наличие объекта"

Отладчик выбрасывает в файл homepage.php

на строку "Show_Attacks_Per_Hour(linechart, preloader);" следующей функции

function autorefresh2(preloader){

// attribute set by Java!!

var head = document.getElementsByTagName('head'); var stopRefresh = head[0].getAttribute('stop');

var ssc = '1';

if (ssc) {

// No I18n!! Used by Java. Make sure Java knows the page is loaded.

self.status = 'status=complete';

}

if (preloader || !stopRefresh) {

Show_Attacks_Per_Hour(linechart, preloader);

Show_getTopAndLatestThreats(preloader);

Show_Virus_Definitions(ids, preloader);

Show_getThreatCon(preloader);

Show_dashboardwatchlistsummary(preloader);

Show_Action_Summary(preloader);

Show_Status_Summary(preloader);

Show_dashboardsecuritystatus(preloader);

Show_Acknowledged_Alerts(preloader);

}

Проблема возникла, предположительно, после установки:

1)Microsoft.Net FrameWork 4 Extended

Microsoft.Net FrameWork 4 Client Profile

Обновлений для предыдущих версий Microsoft.Net FrameWork

Windows Security Update: kb979482

kb979559

kb978695

kb979907

kb980195

kb980218

kb975562

kb982666

2)Также была установка клиента SEP на компьютер с сервером SEP после которой сервер в первый раз не загрузился. Ругаясь на LU Update. После перезагрузки сисетма загрузилась - удалил клиента SEP.

Полная переустановка SEP Manager не решила проблему.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Shell

Надо было новую темку искать. Это не общий вопрос решающийся за минуту.

Без .net 4 ext ошибка есть?

Что в логе C:\Program Files\Symantec\Symantec Endpoint Protection Manager\tomcat\logs\scm-server-0.log ?

Что в журнале приложений?

Что говорит SEP Support Tool? http://www.anti-malware.ru/forum/index.php?showtopic=6170

Также была установка клиента SEP на компьютер с сервером SEP после которой сервер в первый раз не загрузился. Ругаясь на LU Update. После перезагрузки сисетма загрузилась - удалил клиента SEP.

Проблем быть не должно.

Какая конкретно была ошибка?

Подозреваю, что без тикета в суппорте не решить. Так как 4 .net очень многое затрагивает в системе критичное для работы SEP

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
WhiteFox
Надо было новую темку искать. Это не общий вопрос решающийся за минуту.

Пытался найти что-то поближе, не нашел.

Без .net 4 ext ошибка есть?

Попробую снести. Но в дружественной организации, с одинаковым дистрибутивом SEP и обновлениями Windows подобных проблем не наблюдается.

Что в логе C:\Program Files\Symantec\Symantec Endpoint Protection Manager\tomcat\logs\scm-server-0.log ?

Были какие то ошибки. Но они видимо к делу отношения не имеют. Например такие:

2010-07-12 17:40:33.291 SEVERE: Unknown Exception

java.sql.SQLException: JZ006: Caught IOException: com.sybase.jdbc2.jdbc.SybConnectionDeadException: JZ0C0: Connection is already closed.

at com.sybase.jdbc2.jdbc.ErrorMessage.createIOEKilledConnEx(ErrorMessage.java:796)

at com.sybase.jdbc2.jdbc.ErrorMessage.raiseErrorCheckDead(ErrorMessage.java:837)

at com.sybase.jdbc2.tds.Tds.handleIOE(Tds.java:3967)

at com.sybase.jdbc2.tds.Tds.handleIOE(Tds.java:3912)

at com.sybase.jdbc2.tds.Tds.nextResult(Tds.java:2329)

at com.sybase.jdbc2.jdbc.ResultGetter.nextResult(ResultGetter.java:69)

at com.sybase.jdbc2.jdbc.SybStatement.nextResult(SybStatement.java:220)

at com.sybase.jdbc2.jdbc.SybStatement.nextResult(SybStatement.java:203)

at com.sybase.jdbc2.jdbc.SybStatement.queryLoop(SybStatement.java:1614)

at com.sybase.jdbc2.jdbc.SybStatement.executeQuery(SybStatement.java:1599)

at com.sybase.jdbc2.jdbc.SybPreparedStatement.executeQuery(SybPreparedStatement.jav

a:96)

at com.sybase.jdbc2.tds.Tds.getBoolOption(Tds.java:1525)

at com.sybase.jdbc2.jdbc.SybConnection.getAutoCommit(SybConnection.java:1020)

at org.apache.commons.dbcp.DelegatingConnection.getAutoCommit(DelegatingConnection.

java:304)

at org.apache.commons.dbcp.PoolingDataSource$PoolGuardConnectionWrapper.getAutoCommit(PoolingDataSource.java:224)

at com.sygate.scm.server.db.util.DatabaseUtilities.closeConnection(DatabaseUtilitie

s.java:502)

at com.sygate.scm.server.db.util.DatabaseUtilities.getNextUSN_SP(DatabaseUtilities.

java:649)

at com.sygate.scm.server.db.util.DatabaseUtilities.getNextUSN(DatabaseUtilities.jav

a:623)

at com.sygate.scm.server.metadata.StateMetadataCollection.updateMetadata(StateMetad

ataCollection.java:112)

at com.sygate.scm.server.metadata.MetadataManager.updateMetadata(MetadataManager.ja

va:389)

at com.sygate.scm.server.configmanager.ConfigManager.updateStateObject(ConfigManage

r.java:1091)

at com.sygate.scm.server.configmanager.ConfigManager.updateSemServerStateObject(Con

figManager.java:3262)

at com.sygate.scm.server.task.ClientTransportInfoTask.run(ClientTransportInfoTask.j

ava:214)

at java.util.TimerThread.mainLoop(Timer.java:512)

at java.util.TimerThread.run(Timer.java:462)

Тормузнул сервер, почистил логи, после старта полазил по окошкам Менеджера - в логах ошибок не видать.

2010-07-12 18:34:06.417 SEVERE: ================== Server Environment ===================

2010-07-12 18:34:06.417 SEVERE: os.name = Windows 2003

2010-07-12 18:34:06.417 SEVERE: os.version = 5.2

2010-07-12 18:34:06.417 SEVERE: os.arch = x86

2010-07-12 18:34:06.417 SEVERE: java.version = 1.6.0_14

2010-07-12 18:34:06.417 SEVERE: java.vendor = Sun Microsystems Inc.

2010-07-12 18:34:06.417 SEVERE: java.vm.name = Java HotSpot Server VM

2010-07-12 18:34:06.417 SEVERE: java.vm.version = 14.0-b16

2010-07-12 18:34:06.417 SEVERE: java.home = C:\Program Files\Symantec\Symantec Endpoint Protection Manager\jdk\jre

2010-07-12 18:34:06.417 SEVERE: catalina.home = C:\Program Files\Symantec\Symantec Endpoint Protection Manager\tomcat

2010-07-12 18:34:06.417 SEVERE: java.user = null

2010-07-12 18:34:06.417 SEVERE: user.language = ru

2010-07-12 18:34:06.417 SEVERE: user.country = RU

2010-07-12 18:34:06.433 SEVERE: scm.server.version = 11.0.6005.562

2010-07-12 18:34:08.026 SEVERE: ================== StartClientTransport ===================

2010-07-12 18:34:08.323 SEVERE: Schedule is started!

2010-07-12 18:35:10.829 SEVERE: com.sygate.scm.server.util.securitydata.ThreatData: Signature verification failed for Security Response outbreak information.

Что в журнале приложений?

Event Type: Information

Event Source: ASA 9.0

Event Category: None

Event ID: 1

Date: 12.07.2010

Time: 18:28:54

User: N/A

Computer: MFBL02

Description:

The description for Event ID ( 1 ) in Source ( ASA 9.0 ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: ASANYs_sem5; Successfully started service ASANYs_sem5.

А где можно взять описания сообщений?

Что говорит SEP Support Tool? http://www.anti-malware.ru/forum/index.php?showtopic=6170

Тот что шел с дистрибутивом 11.0.6005.562

Ругается что Доступ к файла и принтерам закрыт

Однако 445 порт открыт. Я так полагаю ему 445 должно быть достаточно?

Еще ругается на обновления MS SQL. Но я устанавливал на встроенную базу данных.

Предупреждает что 445 ограничен подсетью. Но у меня все клиенты в ней.

А вот это предупреждение я не понял:

Symantec Security Advisory SYM09-007

Symantec Alert Management System 2 multiple vulnerabilities

Unknown version: 11.0.6005.562

AMS2 is not installed

Symantec Security Advisory SYM09-008

Symantec Reporting Server Improper URL Handling Exposure

Unknown version: 11.0.6005.562

Также была установка клиента SEP на компьютер с сервером SEP после которой сервер в первый раз не загрузился. Ругаясь на LU Update. После перезагрузки сисетма загрузилась - удалил клиента SEP.

Проблем быть не должно.

Какая конкретно была ошибка?

Когда пытался залогиниться Windows ругнулся на LUProxy и повис.

В логах ошибка выглядит так:

Event Type: Error

Event Source: SescLU

Event Category: None

Event ID: 13

Date: 06.07.2010

Time: 18:26:55

User: N/A

Computer: MFBL02

Description:

The description for Event ID ( 13 ) in Source ( SescLU ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: LiveUpdate returned a non-critical error. Available content updates may have failed to install..

У меня в настройках для клиентов был разрешен LiveUpdate. Мне подумалось, что его они и не поделили.

Подозреваю, что без тикета в суппорте не решить. Так как 4 .net очень многое затрагивает в системе критичное для работы SEP

Не подскажите, суппорт только англоязычный?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
WhiteFox
Без .net 4 ext ошибка есть?

Удалил

Microsoft.Net FrameWork 4 Extended

Microsoft.Net FrameWork 4 Client Profile

Ошибка ушла.

Что примечательно. При удалении перегружал машину. После перезагрузки консоль не запускалась - не было файла C:\Program Files\Symantec\Symantec Endpoint Protection Manager\tomcat\webapps\scm\clientpkg\scm-ui.jar

Попробую еще раз накатить 4.Net? может криво встал...

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

  • Сообщения

    • demkd
      А ничего с этим не сделать старые версии windows проблемные там система сама балуется внедрением потоков при очень низком уровне защиты системных процессов, а эцп вообще ничего не гарантирует когда речь заходит о внедренных потоках, зловред вполне может внедрить поток в системный процесс как с помощью подкинутой в правильное место "легитимной" dll, так и просто создав его, а тот уже в свою очередь внедрить в следующий системный и ищи концы среди вот этого вот всего.
      Все это усугубляется тем что тот же SVCHOST.EXE который был когда запущен может оказаться совсем не системным, хотя путь у него будет правильным как и файл будет иметь валидную эцп и запущен он будет якобы services.exe, в 10ке такое провернуть уже сложнее, а вот 7ке легко, потому урезать лог по принципу "оба файла имеют эцп" никак нельзя.
    • PR55.RP55
      uVS v5.0.6v x64 [http://dsrt.dyndns.org:8888]: Windows 7 Home Basic x64 (NT v6.1 SP1) build 7601 Service Pack 1 [C:\WINDOWS] (!) ПРЕДУПРЕЖДЕНИЕ: Ф зафиксировал внедрение потока C:\WINDOWS\SYSTEM32\SERVICES.EXE [428] внедрил поток [380] в процесс: C:\WINDOWS\SYSTEM32\SVCHOST.EXE [876]   C:\WINDOWS\SYSTEM32\SVCHOST.EXE [1060] внедрил поток [1276] в процесс: C:\WINDOWS\SYSTEM32\SVCHOST.EXE [336] и т.д.  А есть ли смысл выводить в лог десяток - другой аналогичных записей, если все эти файлы  в базе проверенных и у них легальная цифровая?  
    • demkd
      ---------------------------------------------------------
       5.0.6
      ---------------------------------------------------------
       o Добавлено 4 новых ключа автозапуска в список для проверки.

       o Добавлен новый статус "UWP".
         Его получают пакеты приложений универсальной платформы Windows (Universal Windows Platform Apps).

       o Добавлен новый твик #46: Отключить Windows Terminal и очистить реестр.
         Если Windows Terminal активен, в лог выдается предупреждение.
         При обнаружении подозрительных настроек Windows Terminal в конфигурационных файлах, реестре или в каталогах с фрагментами в лог выводится предупреждение.
         Если подозрительная строка найдена в JSON-файле настроек, то в список автозапуска добавляется этот файл с содержимым со статусом "подозрительный".
         В любом случае рекомендуется отключить Windows Terminal, а еще лучше немедленно удалить это из системы.
         Windows Terminal — крайне уязвимый и неоптимизированный кусок кода.

       o Улучшена функция масштабирования удаленного рабочего стола, повышено качество аппаратного апскейла, добавлен параметр "Резкость".
         (Требуется D2D и DX11 на клиентском компьютере)

       o Исправлена старая ошибка в функции отправки ответов серверной части uVS.
         Из-за ошибки в редких случаях могло происходить подвисание серверной и клиентской частей uVS при работе с удаленной системой.

       o Исправлена ошибка в функции завершения серверной части при выходе из удаленной системы.

       o Оптимизирована функция подключения к удаленной системе.

       o Оптимизирована функция сжатия фреймов для DDAL/DDAw режимов: шрифты теперь не теряют яркость, а картинка DDAL практически неотличима от DDA1/DDA2 на глаз, 
         при этом размер сжатого фрейма вырос лишь незначительно.

       o Добавлена x64 версия report_crash.

       o Обновалена функция сбора дампа при падении uVS, функция перенесена в утилиту report_crash, что позволит
         получить максимально точную информацию о произошедшей ошибке.

       o Временно добавлена аппаратная функция обнаружения разрушения списка автозапуска в памяти uVS, что позволит отлавливать сложные в обнаружении ошибки.
         Есть 5 дампов, по которым не удалось выяснить точное место ошибки и эта функция должна помочь найти проблемное место.
         Функция снижает скорость формирования списка на ~5% на современных процессорах.

       o Исправлена ошибка в функции подсчета удаленных ключей реестра.

       o Исправлена ошибка в функции записи параметров при выходе из uVS.

       o Исправлена ошибка разбора JSON-файлов.

       o Исправлена ошибка проверки переменных окружения загруженного пользователя.

       o Из списка доступных для подключения IP-адресов удалены адреса активных VPN.

       
    • PR55.RP55
      * адрес страницы (ReferrerUrl) и адрес самого файла (HostUrl) в метке появились в Windows 10 версии 1703, их записывают браузеры, например Edge и Chrome. В статье показано, как посмотреть эти данные в Windows 11 https://www.comss.ru/page.php?id=22105
    • Ego Dekker
      ESET Cyber Security 10.0.2100  (macOS 13/14/15/26/27)
                                                                                  ●
              Руководство пользователя ESET Cyber Security 10  (PDF-файл)
                                                           
      Полезные ссылки:
      Технологии ESET
      Удаление антивирусов других компаний
      Как удалить ESET Cyber Security?
×