Обнаружена уязвимость в стандарте PDF

При работе с программами Adobe Acrobat Reader или Foxit Reader файлы типа PDF могут быть использованы для распространения вредоносного ПО, заявил на днях сотрудник компании NitroSecurity.

Сообщается, что злоумышленник может воспользоваться дополнительной функциональностью обеих программ, позволяющей запускать исполнительный код, записанный в самом файле PDF. Несмотря на то, что компьютер обязательно спросит пользователя, выполнять ли команду, риск заражения компьютера всё равно велик, учитывая, что многие по невнимательности могут нажать "Open".

Результатом заражения станет то, что все PDF-файлы, находящиеся на компьютере будут безвозвратно испорчены, и при попытке их открыть пользователь будет автоматически перенаправляться на "нужный" сайт. Повышению защищенности не способствует ни отключение JavaScript, ни использование конкретной программы для чтения PDF, поскольку уязвимость находится не в самом ПО. В Adobe и Foxit Software уже занялись исследованием проблемы и возможными путями ее исправления. Представители Adobe объяснили, что уязвимость находится в самой спецификации PDF. В Acrobat Reader присутствует предупреждающее сообщение для такого случая, когда в PDF содержится ссылка на команду launch.

Отметим, что хотя новая уязвимость и не связана с программным обеспечением, однако, по данным F-Secure, 61% хакерских атак приходится на одно-единственное приложение – Adobe Acrobat Reader. Из 900 атак за первые 2 месяца 2010 года более 500 пришлось именно на приложение Adobe для чтения PDF-файлов.

Источник

Подпишитесь
в Facebook

Я уже с вами